Blank line in copy

Home Forums General WordPress Questions Blank line in copy

This topic contains 8 replies, has 2 voices, and was last updated by  BartC 7 years, 5 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
Author Posts
Author Posts
July 2, 2010 at 11:02 am #1107

BartC

Hi Jeremy,

As a newbie to WP and Techozoic I have a raft of questions. I’ll post them as separate Qs:

So here is #5:

The page/post text editor in the WP dashboard is not exactly a WYSIWYG view, by design. However, for us newbies, it sometimes is quite frustrating.

I would on occasion like to have a blank line between paragraphs. And, of course, a simple Enter does not do it. That blank line is ignored by the HTML code.

I have resorted to using a line with three dots as a place holder for the blank. I have tried Ctrl-Enter, and a bunch of other combos, all to now avail.

How is that done?

The site is HERE.

This is on WPv3 and Techozoic v 1.8.7

Thanks
bc

July 4, 2010 at 11:52 am #1109

Jeremy Clark

That is just the wordpress visual editor but instead of the … you could switch to the html editor and use this code instead.

<p>&nbsp;</p>

And it will do the same thing instead of … will show just a blank line.

August 1, 2010 at 9:19 pm #1111

BartC

Jeremy,

OK, so there is something I am missing here. I selected the code (which I take to be a paragraph tag, with a space the only content.)

Using the HTML version of the page, I insert it on a line all by itself, and update the page. I use a different browser, and look at the page. Indeed there is a blank line where I placed the code. … so far so good.

I then go back to the page and place another one. Go off and look at the page and indeed there is a blank line where I inserted the second instance of the code, but… the first one disappears!

I look at the HTML version of the page and indeed the first instance of the code is no longer there.

I must be missing something like the 800 pound gorilla, who is just standing in the room, about to sit on me.

The Front Burner

FYI: WP v3.0.1

August 2, 2010 at 3:52 am #1113

Jeremy Clark

Whenever you go back to the page does it go straight to the html editor or does it switch to the visual editor first. If it switches then the visual editor will most likely remove it. If you go to your profile page by clicking on you name in your site’s wp dashboard and then look for the box that says disable visual editor and check it then try it again. I’ve seen the visual editor cause All kinds of problems.

August 2, 2010 at 1:30 pm #1115

BartC

OK, I disabled the visual editor. Stuck the code in all places where I wanted it. And, this time it stuck.

However, what will happen if I re-enable the visual editor? And, then happen to load that page again, to fix a typo or some such. Will the visual editor then strip all my blank lines out?

Would ‘& # 1 6 0 ;’ hold any better than ‘& n b s p ;’ ? Actually, how are they different? And, should this ‘feature’ of the visual editor be reported as a bug.

Thanks…

August 4, 2010 at 3:34 pm #1117

Jeremy Clark

The visual editor will strip them out whenever you save the post. It’s meant to help average users who mistakenly add to many tags. I think I’ve seen a way to change this behavior I’ll have to look around and find it again. I’ll let you know of I find anything.

August 4, 2010 at 6:50 pm #1119

BartC

Thanks Jeremy,

This is a big pain. What do other folks do about inserting blank lines?

Should this not be logged as a bug?

And what about:

Would ‘& # 1 6 0 ;’ hold any better than ‘& n b s p ;’ ? And actually, how are they different?

bc

August 8, 2010 at 6:22 am #1122

Jeremy Clark

The WordPress visual editor is stripping the extra p tags that it thinks are empty. You could try adding this to your custom Css under the style setting page.

#content p {
margin-bottom : 5px;
}

This will give some space to the bottom of your paragraphs. You can adjust the number to get more or less space.

August 14, 2010 at 6:52 pm #1124

BartC

OK, I think I have found a solution to the WP Visual editor removing blank lines. There is plugin called:

TinyMCE Advanced by Andrew Ozz.

This plugin seems to take a blank line in the Visual Editor and places this code on a line:

<p><br class="spacer_" /></p>

at that location. If not careful one will actually end up with more blank lines than intended. This plugin also adds additional function buttons to the Visual Editor tool bar.

I don’t understand all the options it has, but the bit for blank lines needs to be selected on its setup page that gets created under Settings.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Blank line in copy

Home Forums General WordPress Questions Blank line in copy

This topic contains 8 replies, has 2 voices, and was last updated by  BartC 7 years, 5 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
Author Posts
Author Posts
July 2, 2010 at 11:02 am #1108

BartC

Hi Jeremy,

As a newbie to WP and Techozoic I have a raft of questions. I’ll post them as separate Qs:

So here is #5:

The page/post text editor in the WP dashboard is not exactly a WYSIWYG view, by design. However, for us newbies, it sometimes is quite frustrating.

I would on occasion like to have a blank line between paragraphs. And, of course, a simple Enter does not do it. That blank line is ignored by the HTML code.

I have resorted to using a line with three dots as a place holder for the blank. I have tried Ctrl-Enter, and a bunch of other combos, all to now avail.

How is that done?

The site is HERE.

This is on WPv3 and Techozoic v 1.8.7

Thanks
bc

July 4, 2010 at 11:52 am #1110

Jeremy Clark

That is just the wordpress visual editor but instead of the … you could switch to the html editor and use this code instead.

<p>&nbsp;</p>

And it will do the same thing instead of … will show just a blank line.

August 1, 2010 at 9:19 pm #1112

BartC

Jeremy,

OK, so there is something I am missing here. I selected the code (which I take to be a paragraph tag, with a space the only content.)

Using the HTML version of the page, I insert it on a line all by itself, and update the page. I use a different browser, and look at the page. Indeed there is a blank line where I placed the code. … so far so good.

I then go back to the page and place another one. Go off and look at the page and indeed there is a blank line where I inserted the second instance of the code, but… the first one disappears!

I look at the HTML version of the page and indeed the first instance of the code is no longer there.

I must be missing something like the 800 pound gorilla, who is just standing in the room, about to sit on me.

The Front Burner

FYI: WP v3.0.1

August 2, 2010 at 3:52 am #1114

Jeremy Clark

Whenever you go back to the page does it go straight to the html editor or does it switch to the visual editor first. If it switches then the visual editor will most likely remove it. If you go to your profile page by clicking on you name in your site’s wp dashboard and then look for the box that says disable visual editor and check it then try it again. I’ve seen the visual editor cause All kinds of problems.

August 2, 2010 at 1:30 pm #1116

BartC

OK, I disabled the visual editor. Stuck the code in all places where I wanted it. And, this time it stuck.

However, what will happen if I re-enable the visual editor? And, then happen to load that page again, to fix a typo or some such. Will the visual editor then strip all my blank lines out?

Would ‘& # 1 6 0 ;’ hold any better than ‘& n b s p ;’ ? Actually, how are they different? And, should this ‘feature’ of the visual editor be reported as a bug.

Thanks…

August 4, 2010 at 3:34 pm #1118

Jeremy Clark

The visual editor will strip them out whenever you save the post. It’s meant to help average users who mistakenly add to many tags. I think I’ve seen a way to change this behavior I’ll have to look around and find it again. I’ll let you know of I find anything.

August 4, 2010 at 6:50 pm #1120

BartC

Thanks Jeremy,

This is a big pain. What do other folks do about inserting blank lines?

Should this not be logged as a bug?

And what about:

Would ‘& # 1 6 0 ;’ hold any better than ‘& n b s p ;’ ? And actually, how are they different?

bc

August 8, 2010 at 6:22 am #1121

Jeremy Clark

The WordPress visual editor is stripping the extra p tags that it thinks are empty. You could try adding this to your custom Css under the style setting page.

#content p {
margin-bottom : 5px;
}

This will give some space to the bottom of your paragraphs. You can adjust the number to get more or less space.

August 14, 2010 at 6:52 pm #1123

BartC

OK, I think I have found a solution to the WP Visual editor removing blank lines. There is plugin called:

TinyMCE Advanced by Andrew Ozz.

This plugin seems to take a blank line in the Visual Editor and places this code on a line:

<p><br class="spacer_" /></p>

at that location. If not careful one will actually end up with more blank lines than intended. This plugin also adds additional function buttons to the Visual Editor tool bar.

I don’t understand all the options it has, but the bit for blank lines needs to be selected on its setup page that gets created under Settings.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.