Fatal error: allowed memory exhausted

Home Forums General WordPress Questions Fatal error: allowed memory exhausted

This topic contains 2 replies, has 2 voices, and was last updated by  Jeremy Clark 5 years, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
Author Posts
Author Posts
October 22, 2011 at 12:33 pm #1719

BartC

I have been using the Jetpack plug in with only the Stats and Twitter widget enabled.

It seemed to run just fine for about a month. But I have received the following errors:

A user with Author attributes could not see stats or get a log out prompt. The errors were:

Fatal error: allowed memory size of 33554432 bytes exhausted (tried to allocate 64049 bytes) in /data/user/xxxxxx06/htdocs/main/wp-content/plugins/jetpack/modules/stats.pho on line 296

Fatal error: allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /data/user/xxxxxx06/htdocs/main/wp-includes/class-simplepie.php on line 3736

I logged in as admin, and deactivated jetpack and that fixed the issue for the author user.

The next day I logged on as admin, and reactivated Jetpack. The site remained avaible for the public, but I could not get to the dashboard with the following error showing on a blank page:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 491520 bytes) in /data/user/xxxxxx06/htdocs/main/wp-admin/menu.php on line 254

I did a FTP to the site and deleted the Jetpack folder, and I could once again access the dashboard.

Q#1: who is user 2373306? Is that the ID for the jetpack plugin? Different users were logged on when those errors hit, but it always is the same number.

Q#2: what in general is happening? Allowed memory size seems huge, yet something (Jetpack with only two modules active?) seems to be hitting the wall.

NB: with the old WordPress Stats plugin (which is now part of Jetpack) I never had any memory issues. From the host manager’s page it tells me that I’ve only used 4% of my allowed SQL space and the WordPress front end is using only 11% of my allowed space.
version info: WP v3.2.1; Techozoic Fluid v1.9.4

So I don’t know what the problem is or what to do about it.

October 26, 2011 at 5:17 am #1720

Anonymous

I’ve been having the same issue and have narrowed the trouble down to Jetpack. My solution is going to be to remove Jetpack entirely and find other, lighter plugins to do the same job. Sorry I don’t have a better solution; just wanted you to know you’re not the only one with Jetpack troubles.

October 26, 2011 at 11:39 am #1721

Jeremy Clark

You should have a talk with your host and see if they can help you increase your php memory limit. 32Mb is fairly small now.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.