Fatal error: Only variables can be passed by reference in /home/content

Home Forums Techozoic Fatal error: Only variables can be passed by reference in /home/content

This topic contains 3 replies, has 2 voices, and was last updated by  Jeremy Clark 8 years ago.

Viewing 4 posts - 1 through 4 (of 4 total)
Author Posts
Author Posts
November 20, 2009 at 3:57 am #535

smellycat3

I have installed your Techozoic template on smellycatproducitons.com/blog. The template is great, but whenever I try to publish a post, the template goes haywire, my post disappears, and I get the following error message in the sidebar:

Fatal error: Only variables can be passed by reference in /home/content/s/m/e/smellycat/html/blog/wp-content/themes/techozoic-fluid/functions.php on line 25

I am using Firefox for a browser. Any suggestions?

November 20, 2009 at 12:33 pm #536

Jeremy Clark

Are you using PHP 5.0.5 there is a bug specific to that version but it doesn’t exist in 5.0.4 or 5.0.6 +. If you can upgrade or downgrade php versions and try it again.

January 17, 2010 at 11:12 pm #537

Jeremy Clark

I’d like to use this theme but I do not have the option to change my php version. Do you have another solution? Thanks

January 17, 2010 at 11:45 pm #538

Jeremy Clark

After quite a bit of digging I think I’ve found the soultion. I’ve made the change in the upcoming release of 1.8 of Techozoic, but until then you can make the changes yourself in the functions.php file look for this block of code.

add_filter(‘get_comments_number’, ‘comment_count’, 0);
function comment_count( $count ) {
global $id;
$comments_by_type = &separate_comments(get_comments(‘post_id=’ . $id));
return count($comments_by_type[‘comment’]);
}

You need to replace it with this block.

add_filter(‘get_comments_number’, ‘comment_count’, 0);
function comment_count( $count ) {
global $id;
$get_comments= get_comments(‘post_id=’ . $id);
$comments_by_type = &separate_comments($get_comments);
return count($comments_by_type[‘comment’]);
}

I hope this helps. Please if you wouldn’t mind letting me know for sure if it solves the problem, Thanks.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.