Header issues with upgrade

Home Forums Techozoic Header issues with upgrade

This topic contains 10 replies, has 2 voices, and was last updated by  Jeremy Clark 6 years, 3 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
Author Posts
Author Posts
October 30, 2010 at 4:01 am #1293

BartC

Hi Jeremy,

So I finally did the upgrade, and it seemed to go reasonably smooth, except for a header pix issue.

After the upgrade only the default headers were available. So I looked around and found two directories called headers, so I loaded both with my custom header pixs.

They were:

/htdocs/main/wp-content/themes/techozoic-fluid/images/headers

/htdocs/main/wp-content/techozoic/images/headers

BUT, that did not fix the problem. I could not see those files in the techozoic_header_admin page. So I did a manual upload on that page from my locally stored backups. That seemed to load to:

/htdocs/main/wp-content/themes/techozoic-fluid/uploads/images/headers

yet a third dir called headers. Now, I could see the files listed in the header admin page, but I could not preview them from there, and they do not show up on viewing the site.

What’s up!!!

http://www.thefrontburner.us

NB: I left your login up.

October 30, 2010 at 7:59 pm #1294

BartC

So in trying to figure this lack of header pixs I looked at dir and file permissions:

for:

/htdocs/main/wp-content/themes/techozoic-fluid/images/headers

the dir is 755 and the files are 664

for:

/htdocs/main/wp-content/techozoic/images/headers

the dir is 755 and the files are 644

and for what may be the real one:

/htdocs/main/wp-content/themes/techozoic-fluid/uploads/images/headers

the dir is 750 and the files are 664

I don’t know if any of the above is relevant.

The rotate.php file is at:

/htdocs/main/wp-content/themes/techozoic-fluid

Also based of a previous post (perhaps dealing with a previous version) on 6/25/10

Jeremy Clark said:

Ok to get the rotate working again you’ll need to look in the techozoic-fluid folder in the wp-content/themes folder and copy the rotate.php file from there and put it into the root of the wp-content/techozoic folder. So the structure would look like this.

wp-content
-techozoic
–images
–rotate.php


I also placed a copy of rotate.php at:

/htdocs/main/wp-content/techozoic/images

And it didn’t make any difference… still broken.

bc

October 31, 2010 at 3:51 am #1295

Jeremy Clark

All the headers are now stored in wp-content/themes/techozoic-fluid/uploads/images/ with two folders headers and backgrounds. Also rotate.php should be in the images folder. I’ve had to modify where files where stored to be able to submit the theme to the wp directory. You’ll need to make sure that the /images and all subfolders are writable by the web server and readable by everyone. Try 775 for the images and all subfolders. This seems to be the problem.

October 31, 2010 at 9:50 pm #1296

BartC

Jeremy,

OK, so I FTP’d to wp-content/themes/techozoic-fluid/uploads/images/ and changed attributes to 775. I had FileZilla recursively apply 775 to the images dir and dirs and files below. I checked the two dirs (headers and backfrounds)and some random files and they were 775.

However, NO fix! Just a blank header!

I placed rotate.php in the images dir (it was not there) and changed attributes to 775. Still no fix!

So just to try it I also changed attributes to 775 on the two other dir for headers:

/htdocs/main/wp-content/themes/techozoic-fluid/images/headers

and

/htdocs/main/wp-content/techozoic/images/headers

and still no fix!

I see the header files listings in the techozoic_header_admin page but I still can not preview them. (click on preview and it just sits there twirling the striped bar forever.)

One other issue I just noticed. On Firefox and Safari the bottom of the title box over lays the menu row. And on IE8 the menu does not appear at all.

What to do?

bc

October 31, 2010 at 10:22 pm #1297

BartC

OK, so here is some additional info:

If I don’t rotate the headers and just pick your Landscape.jpg (998 x 160) (in the techozoic_header_admin page) the title box over laps the menu bar. NB: the menu bar still does not show on IE8.

If I pick any of my other custom header pixs (1000 x 200) the title box does NOT overlap the menu bar.

So some how the jpg size is being read and a box is there to hold the header pix, but the content for that box does not appear. Also I don’t recall that the title box over lapped the menu for the Landscape jpg in the previous theme version.

After this dust settles, I would like to know what directories I can delete to save server space, since there seems to be some redundancy with the theme upgrade.

And, I’m not even sure if I have the correct rotate.php file. Did they change between versions, perhaps I grabbed an old copy to place in the images subdir.

bc

November 2, 2010 at 7:05 am #1298

Jeremy Clark

Whenever the landscape is picked I’ve set it so the header area is resized smaller. All the rest of the headers should have 200px heights. I’ll contact you by email so I can get a better look at your file structure and try to figure this problem.

November 3, 2010 at 4:50 pm #1299

BartC

So I still can’t figure out what is going on, and I await your investagation. In the meantime I have stubmled on some things:

If I right click on the blank area where the header picture should be and ask to see the background image, I get a small png that is 10×1, and is located here:

http://thefrontburner.us/main/wp-content/themes/techozoic-fluid/images/bgr.png

and indeed in that location is that png file. And of course under the images dir is another headers and backgrounds folder.

Also, I resized the landscape jpg to 1000 x 200 so when it rotates through it won’t overlap the menus.

2nd also… biggie… there are no menus when site is viewed in IE8!!!

bc

November 4, 2010 at 12:19 am #1300

BartC

So here is more info, and very confusing it is:

The menus do not appear on my laptop copy of IE8 (v8.0.60001.18702). So now at work, it seems the corporate desktop has the very same version of IE8. And, the menus DO appear.

On my laptop I have Firefox, Chrome, Safari, and of course IE, to see how the site looks in those browsers. The previous version of Techozoic showed menus on all four browsers. But with the upgrade the menus disappeared on IE8 (my copy).

I changed the screen res on the laptop, up to the native (1920 x 1200) and down to something less, and the menus did not appear.

Also on the frame around the post there is a break on the left and right edge where the menu bar would be. Also, I have the widget for text size and the menu doesn’t show at any text size or zoom.

Yikes…

bc

PS: Something new…
I just tried toggling the IE8 Compatibility mode.

Tools > Compatibility Mode

With compatibility OFF the menus can be seen, with compatibility ON the menus disappear.

I don’t have access to IE6 to see what it would show.

November 4, 2010 at 3:01 am #1301

BartC

For the sake of all our viewers out there…

The permissions were set incorrectly for the uploads folder and for the rotate.php file. They should be 755 so that everyone
can read and execute. For folders this means read and traverse into folder.

Thanks Jeremy… Problem solved…

bc

November 22, 2010 at 9:30 am #1302

Anonymous

I have a similar issue, but not the same. I have two issues with my header. One is that it’s not showing up in IE8, the other is that all headers are overlapping the container box.

This seems to have been since the upgrade. Any suggestions?

Thanks
AK

December 4, 2010 at 4:35 pm #1303

Jeremy Clark

I have not seen the problem with header images in IE but I’m aware of an overlap problem with certain header options. I have since fixed the problem in the next version that is set to be release soon.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.