installing Google font

Home Forums Techozoic installing Google font

This topic contains 9 replies, has 2 voices, and was last updated by  Monica 6 years ago.

Viewing 10 posts - 1 through 10 (of 10 total)
Author Posts
Author Posts
September 7, 2011 at 5:10 pm #1662

Monica

Hi,
I’m trying trying to install a Google font following the steps on the ‘General Settings’ page of the Techozoic Settings section, (v.1.9.4). It seems there should be something else to do besides “enter the ‘Font API parameter name'” as it tells me to do, and I have the code from the Google font page, but I don’t know where to put it. Help? Confused

I’m using WP v.3.2.1.

Thanks.

September 7, 2011 at 5:40 pm #1663

Monica

Well, it seemed that was enough, because the font did install — except I can’t seem to change my Blog Subtitle – the tag line under the title of my blog. It doesn’t seem to be attached or associated with the Blog Title, and I can’t seem to find how to change it. While I’m at it, it’s way too small! The blog tag line isn’t listed in the Typography section where I can change the size of the headings or titles. And so it seems I can’t change the font of the tag line either! But I want it to match my Blog Title, so I need to fix this. Help! Surprised

September 8, 2011 at 3:18 pm #1664

Jeremy Clark

To add the google font to the subtitle you’ll need to add some css to the custom css box of the style settings tab. You find this by going to Appearence -> Techozoic Settings then click on the Style Settings tab on the top of the page. Then you just add the above code right into the Custom CSS box there. You can refer to this screenshot of the option page. http://techozoic.clark-technet.com/wp-content/uploads/2010/09/Style-Settings.jpg

This code should change the size and the font face. You’ll need to change the Google Font to the name of your google font that you’ve chosen. If there are any spaces in the name make sure to wrap the name in single quotes.

.description{
font-size: 14px;
font-family: ‘Google Font’;
}
September 9, 2011 at 11:20 am #1665

Monica

Thanks so much, Jeremy. This partially worked. The code change the font size, but now the tag line copy is in Times New Roman. I’m trying to use Google font ‘Special Elite’ and I replaced ‘Google font’ with that, just like that, inside the single quotes. Is it possible that copy can’t take certain fonts?

Thanks!

September 9, 2011 at 12:11 pm #1666

Jeremy Clark

It seems to be working now. Might need to force a browser refresh with CTRL + F5.

September 12, 2011 at 7:33 pm #1667

Monica

Not working on my browser (Chrome) still, even after hitting F5/CRL-F5.

September 15, 2011 at 9:15 am #1668

Jeremy Clark

Yes I’m seeing it now too on chrome. I neglected to try it with chrome, it was working with ie and firefox. I think I see the problem. I’ll work on a patch. You can download the latest version from here: https://github.com/jeremyclark13/Techozoic-Fluid/zipball/master Give me a couple hours to track down and test the problem then you can try this new version. There have been a couple of bug fixes since 1.9.4 that are also included in this version.

September 17, 2011 at 11:36 am #1669

Monica

Thank you, Jeremy. That did the trick. The font is now correct. Thanks for all your work.

Now didn’t I read in another post that the bug in the “About” widget would be fixed in the next update? I never posted on this problem after I saw that post, figuring you’re working on it. Just so you know, it’s still not working correctly. (In case you had worked on that already.)

Thanks again,
Monica

September 27, 2011 at 3:11 pm #1670

Jeremy Clark

Thanks for the reminder. I’m working on a major overhaul right now, so it might be a little while before I can get to it. I’ll post here if I find a quick fix though.

September 28, 2011 at 7:28 am #1671

Monica

Actually, Jeremy, after I posted that reply, the About widget started showing the correct links (Facebook & Twitter, and not MySpace). I just didn’t want to post what seemed a useless post.

It seems it takes a while for some changes to take effect, no matter how many times you hit that F5. I should try to have more patience! I will add that lately (since my last post), the changes seem to be taking much faster.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.