Page and post formatting

Home Forums Techozoic Page and post formatting

This topic contains 4 replies, has 2 voices, and was last updated by  Anonymous 8 years, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
Author Posts
Author Posts
December 11, 2009 at 10:29 am #579

Anonymous

I am working with this theme, and I’m noticing that when I activate this theme, it trashes my formatting. For example, when I have a bulleted list, it left justifies the entire list, rather than allowing for the indentions.

A list like:

  1. Bar
  2. Bar

will end up flattened against the left, and if I add nested lists, it stays in one column, rather than indenting.

Is there a way to work around this? I often need a little more flexible formatting for my posts and pages, but this theme rocks.

December 11, 2009 at 10:33 am #580

Anonymous

So, when I am in the lists of posts, the formatting looks okay, but when I display a page, or an individual post’s entry, it scrams the formatting.

December 11, 2009 at 12:45 pm #581

Anonymous

This appears to fix it:

# svn diff
Index: single.php
===================================================================
— single.php	(revision 5)
+++ single.php	(working copy)
@@ -26,7 +26,7 @@
 <a href=""><img src="/images/home.gif" border="0″ alt="TOP" title="Go back to " /> <a href="http://del.icio.us/post?url="><img src="/images/delicious.gif" title="del.icio.us this!" alt="del.icio.us" />
 <a href="http://digg.com/submit?phase=2&url=&title="><img src="/images/digg.gif" title="DIGG this!" alt="digg" />
 	
-			
+
<?php the_content('

Read the rest of this entry »

'); ?> Index: page.php =================================================================== — page.php (revision 5) +++ page.php (working copy) @@ -17,7 +17,7 @@ <div class="post" id="post-"> <!–

–> -
+
<?php the_content('

Read the rest of this page »

'); ?> <?php link_pages('Pages: ', '

', 'number'); ?> @@ -33,4 +33,4 @@ <?php if ($tech_single_sidebar == "Yes" && $techcolumn != 1) { get_sidebar(); if ($techcolumn == 3 && $tech_sidebar_pos =="Content – Sidebar – Sidebar") {include (TEMPLATEPATH . '/l_sidebar.php'); } } ?> - No newline at end of file + Index: attachment.php =================================================================== — attachment.php (revision 5) +++ attachment.php (working copy) @@ -12,7 +12,7 @@ ID); $classname = ($_post->iconsize[0] <div class="post" id="post-">

<a href="post_parent); ?>" rev="attachment">post_parent); ?> » <a href="" rel="bookmark" title="Permanent Link: ">

-
+
<p class=""> guid); ?>

<?php the_content('

Read the rest of this entry »

'); ?>

December 11, 2009 at 12:56 pm #582

Jeremy Clark

The code got garbled on the last post but if you change the class on the single.php from entrytext to entry it should start working, the same for the page template. I’ve also fixed the problem in the next version of Techozoic.

December 12, 2009 at 5:23 am #583

Anonymous

Yeah, that was what I did. I also did so in attachments.php, though I’m not sure what that affects.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.