WP default email address

Home Forums Techozoic WP default email address

This topic contains 2 replies, has 2 voices, and was last updated by  BartC 4 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
Author Posts
Author Posts
July 17, 2013 at 9:58 am #2886

BartC

I just moved my site to a new host. Both the site host and the mail servers for the domain were moved to Bluehost. (Much better than the old host at Network [no]Solutions.)

There is one issue that I can not seem to get to. When new users register for the site, WP calls:

wp-login.php?action=register

Once a user registers, an email is sent correctly to the new user. However, an email should also be sent to the email address on the
Settings > General
page. The email on this page is correct, and I have re-saved it so it would rewrite.

But the new user registration note instead is sent to the wrong address. We do receive the email notice, but only because of how the email server is set up. The site was moved before the email addresses were set up on the new host, so somewhere WP got the wrong address. Bluehost has a KB item on this: KB #206. Part of it reads as follows:
************************************************

Problem:
Why do scripted e-mails come from < [email protected]###.BlueHost.com > when I have specified otherwise?

Solution:
This is because our servers require you (or your script) to use a properly formatted, valid From: field in the email’s header. If the From: field is not formatted correctly, empty or the email address does not exist …the From: address will be changed to [email protected]###.BlueHost.com.

You must change the script you are using to correctly use a valid From: header.

*************************************************
It also goes on to suggest that one could use the WP plugin called:

Mail From at:
http://wordpress.org/plugins/mail-from/

But this is quite an old plug in, and it does not seem (in looking at the PHP) to fix the issue, it just gets WP to use the plug in for email, rather than fix the underlying issue. I think that if I were to install and then remove the plugin the problem would return.

So which PHP file, and where does it live, that has this mal-formed From header. I would simply like to edit it directly.

bc
AdriBarrCrocetti.com

July 17, 2013 at 10:02 am #2889

Jeremy Clark

What I’ve found works much better than the WP mailing function is to use this plugin: http://wordpress.org/plugins/smtp/ to enable the mail to be sent thru your existing smtp server.

September 28, 2013 at 4:22 pm #2914

BartC

Solved!

I edited the sendmail line in the php.ini to be the following:

; For Unix only. You may supply arguments as well (default: “sendmail -t -i”).
sendmail_path = /usr/sbin/sendmail -t -i -f’[email protected]

Replacing [email protected] (of course) with the real email address, using the one that is at:

Dashboard > Settings > General panel

Now all emails arrive with the correct headers.

bc

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.